Reservation Confirmation Code Missing from Reviews

Incident Report for Airbnb API

Resolved

This incident has now been resolved. We released fix yesterday (March 29) at around midnight PT, and confirmed that reservation confirmation codes are being returned for new reviews and reservation alteration created/voided webhooks. To avoid creating unexpected issues on your integration, we are only backfilling those webhooks upon request. You can use the GET Reviews and GET Reservation Alterations APIs to backfill the missing reservation confirmation codes. Alternatively, reach out to the API Integrations Team through the Support Portal if you want us to backfill these webhooks for you.
Posted Mar 30, 2022 - 02:47 PDT

Monitoring

We released a fix for this issue, which should resolve the problem with missing reservation confirmation code in reviews and reservation alteration webhook notifications. We will continue to monitor this closely.
Posted Mar 29, 2022 - 08:01 PDT

Update

We have also discovered that "reservation_alteration_created" and "reservation_alteration_voided" webhooks are missing the reservation confirm code since March 25th. Please be assured that we are continuing our efforts to resolve this issue as fast as possible. Apologies for the inconvenience.
Posted Mar 28, 2022 - 08:53 PDT

Identified

We have identified an issue where reservation confirmation code is missing from the GET Reviews API as well as review webhooks. It started at approximately March 25 at 00:00 UTC. We are looking into the matter with urgency, and will post updates as soon as we have more information. We apologize for the inconvenience.
Posted Mar 25, 2022 - 06:45 PDT