Issues Affecting Guest Name Parameters in Webhooks
Incident Report for Airbnb API
Resolved
This incident has been resolved. However, there remains a minor possibility that reservation acceptance confirmation webhooks may be sent without the guest's last name due to an Airbnb race condition. In case you encounter this issue, please you can retrieve the missing information with the GET Reservations API.

We apologize for the inconvenience this may have caused and don't hesitate to reach out if you have any questions, or require further assistance.
Posted Jun 19, 2023 - 07:46 PDT
Identified
Unfortunately, the mitigation did not resolve the issue and we are still seeing reservation acceptance confirmation webhooks missing the guest last name. Please know our engineering teams are working to get this issue resolved, and we will update you with the latest information as soon as possible. Meanwhile, please use the GET reservations API for any reservations that did not include the guest last name within the webhooks. We apologize for the inconvenience.
Posted Jun 14, 2023 - 16:46 PDT
Monitoring
We have implemented a fix for this issue and are monitoring the results. Apologies for the inconvenience caused.
Posted Jun 12, 2023 - 08:41 PDT
Identified
The issue has been identified and we are working on a fix.

Meanwhile, please attempt GET reservations requests for any reservations that did not include the guest names in full within the webhooks.
Posted Jun 09, 2023 - 00:12 PDT
Investigating
We are currently investigating an issue where guest names are not returned in full within webhooks - namely the reservation acceptance confirmation webhooks. This is not a widespread issue and is only affecting a small percentage of webhooks.

Alternatively, you may be able to retrieve the details with GET reservations requests.

We will post updates as soon as we know more.

Apologies for the inconvenience caused and thank you for your understanding.
Posted Jun 08, 2023 - 19:36 PDT